jQuery 1.9使用$.support替代$.browser方法

jQuery 从1.9版开始,移除了 $.browser 和 $.browser.version , 取而代之的是 $.support 。 在更新的 2.0 版本中,将不再支持 IE 6/7/8。 以后,如果用户需要支持 IE 6/7/8,只能使用 jQuery 1.9。 如果要全面支持 IE,并混合使用 jQuery 1.9 和 2.0, 官方的解决方案是:

  1. <!--[if lt IE 9]> 
  2.     <script src='jquery-1.9.0.js'></script> 
  3. <![endif]--> 
  4. <!--[if gte IE 9]> 
  5.     <script src='jquery-2.0.0.js'></script> 
  6. <![endif]--> 

从长久来看,这样有利于在复杂情况下根据浏览器特性进行分别处理, 而不是简单的检测浏览器类型和版本。 但目前很多旧程序的移植恐怕无法直接过渡为根据浏览器支持特性, 所以在网上找了一些能够直接替换的解决办法。

判断浏览器类型:

  1. $.browser.mozilla = /firefox/.test(navigator.userAgent.toLowerCase()); 
  2. $.browser.webkit = /webkit/.test(navigator.userAgent.toLowerCase()); 
  3. $.browser.opera = /opera/.test(navigator.userAgent.toLowerCase()); 
  4. $.browser.msie = /msie/.test(navigator.userAgent.toLowerCase()); 

等号后面的表达式返回的就是 true/false, 可以直接用来替换原来的 $.browser.msie 等。如需要检查是否为 IE6时,可以这么写:

  1. // Old 
  2. if ($.browser.msie && 7 > $.browser.version) {} 
  3. // New 
  4. if ('undefined' == typeof(document.body.style.maxHeight)) {}  

检查是否为 IE 6-8:

  1. if (!$.support.leadingWhitespace) {}  

转载请注明:代码家园 » jQuery 1.9使用$.support替代$.browser方法

评论列表(网友评论仅供网友表达个人看法,并不表明本站同意其观点或证实其描述)